Tekeez - Big British Mailbox Login Issues – Incident details

All systems operational

Big British Mailbox Login Issues

Resolved
Operational
Started about 3 years agoLasted about 2 hours

Affected

Email Services

Operational from 10:55 AM to 12:39 PM

Big British Mailbox

Operational from 10:55 AM to 12:39 PM

Updates
  • Resolved
    Resolved

    Login issues are now all resolved.

  • Identified
    Identified

    Some customers are being repeatedly asked to login to their email accounts. This issue has been identified and engineers are working on a fix.