Tekeez - Issues with Tekeez Voice Phone System – Incident details

All systems operational

Issues with Tekeez Voice Phone System

Resolved
Operational
Started almost 2 years agoLasted 1 day

Affected

Telephone Services

Operational from 11:03 AM to 11:54 AM

Tekeez Voice

Operational from 11:03 AM to 11:54 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    There is currently an issue with making/taking calls with the Tekeez Voice phone system. Engineers are continuing to work on a fix for this incident.