Tekeez - Problems with Tekeez Voice – Incident details

All systems operational

Problems with Tekeez Voice

Resolved
Degraded performance
Started 3 days agoLasted about 4 hours

Affected

Telephone Services

Degraded performance from 10:26 AM to 2:10 PM

Tekeez Voice

Degraded performance from 10:26 AM to 2:10 PM

Updates
  • Resolved
    Resolved

    Everything has been resolved and should be back to normal.

  • Investigating
    Investigating

    Issues with Tekeez Voice making and receiving calls due to an outage. Engineers are working on this and hope to have a fix as soon as possible.