Tekeez - Issue on Tekeez Voice causing degradation on calls – Incident details

All systems operational

Issue on Tekeez Voice causing degradation on calls

Resolved
Degraded performance
Started 2 days agoLasted about 1 hour

Affected

Telephone Services

Degraded performance from 11:01 AM to 11:50 AM

Tekeez Voice

Degraded performance from 11:01 AM to 11:50 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved and everything should be back to normal.

  • Investigating
    Investigating

    The engineers have identified an issue causing degradation on calls and are working to resolve this as soon as possible.